ETSI v1.8.1 Update for Low-Power Bluetooth Modules

September 22, 2014, 7:00 am

Recently, the European Telecommunications Standards Institute (ETSI) updated two GHz band standards mandatory for market access in Europe. Laird’s MSD30AG/SSD30AG, 40NBT Series, WB45NBT, and MSD45N/SSD45N have all been successfully tested to the new standard, version 1.8.1 of EN 300 328. In addition, Laird is pleased to announce that the BTM400 series of Bluetooth modules is now also fully compliant with the newest ETSI standard. Laird is currently working to have the remaining Bluetooth product lines fully certified before the new standard takes effect in January 2015.

Comprised of the BTM410, BTM411, BTM420, BTM421, BTM430, BTM431, BTM441, BTM443, and BTM461, the 400 Series of Bluetooth modules from Laird has been designed to add robust, short range Bluetooth data connectivity to devices. Each module in the series provides exceptionally low power consumption with outstanding range. The BTM400 series modules are the ideal choice for applications where designers need both performance and minimum size.

Please visit the Embedded Wireless Solutions webpage for information regarding the BTM400 series or Laird’s other product lines. Click here for access to the Embedded Wireless Solutions support center which serves as an additional resource for customers seeking support materials and documentation. The support center provides support for all of Laird’s products via an online ticketing system which enables device makers to troubleshoot and resolve field issues quickly throughout the entire development process. Links to documentation and software for Laird radios, support articles on related topics, video demonstrations, and community questions can also be accessed from the support site.

For additional CE guidance, contact the wireless certifications group via wireless.certifications@lairdtech.com.

More information can also be found in the following official ETSI documents:

ETSI EN 300 328 V1.7.1 (2006-10)

Final draft ETSI EN 300 328 V1.8.1 (2012-04)